[Tuto] Installer Preware, le Cydia du TouchPad

La TouchPad d’HP sera d’ici quelques jours dans tous les foyers de France, du moins pour ceux qui ont pu en commander une après les mégas braderies des revendeurs français… Voici donc un petit tuto assez simple qui vous permettra d’installer Preware, le Cydia du TouchPad. Nombreux patchs, applications, hacks, thèmes, etc, sont disponibles sur ce store et ce gratuitement !

Pré-requis :

Premièrement il faut passer sa tablette en Developer Mode. Direction donc la zone “Tapez maintenant” et inscrivez le code ‘ webos20090606 ‘. Touchez l’icone “Dev mode” et activez ce dernier (inutile de rentrer un mot de passe) en passant sur “Oui” en haut à droite de l’écran !

Après cela, direction le PC. Lancez WebOSQuickInstall-4.4.0.jar et installez le driver novacom (si on vous le propose, nécessaire au bon fonctionnement). Une fois fait, branchez votre TouchPad grâce au câble USB et ne touchez à rien ! Il ne faut pas passer la tablette en mode stockage de masse.

Méthode 1 :

Une fois branché, cliquez sur le petit globe afin d’accéder au store. Une fois chargé, tapez “Preware” dans le champ de recherche et installez-le ! Une fois fini, fermez le logiciel et débranchez votre TouchPad : l’installation est terminé !

Méthode 2 :

Si lorsque vous cliquer sur le globe vous avez une erreur, télécharger [ceci], décompressez-le et glissez le fichier org.webosinternals.preware.ipk et glissez-le dans la fenêtre. Cliquez enfin sur installer pour finaliser l’opération.

Direction le TouchPad pour lancer l’application Preware et profiter du monde underground de webOS. Voici quelques screens de l’application ainsi que ses différentes catégories. Si vous avez des questions, n’hésitez pas !

Roxarmy Auteur

Blogueur durant ses heures perdues. Adore l'informatique, les mangas et le high-tech mais aussi et surtout jouer !

Commentaires

    morlorc

    (25 août 2011 - 17:16)

    Ha un tuto :)
    C’est gentil mais moi j’en ai pas l’utilité ^^

    Xianyou

    (25 août 2011 - 23:09)

    Moi non plus malheureusement x)
    (mais par contre je pense que d’autres le trouveront très utile en tout cas :D )

    hany

    (26 août 2011 - 01:05)

    Genial! Merci bcp, c’est du très bon boulot

    Skorpichou

    (27 août 2011 - 12:57)

    Merci beaucoup, super tuto !

    Signé:
    un des premiers heureux acquéreur de la Touchpad le lundi 22/08 !

    Manu

    (27 août 2011 - 20:30)

    Bonjour, cela ne fonctionne pas chez moi, la tablette est bien à jour en 3.0.2, je suis les instructions et le logiciel WebOS Quick Install ne détecte pas la tablette (que ça soit sous XP ou W7) “il n’y a pas de dispositifs actuellement connecté. S’il vous plait connecter un périphérique de continuer” (oui oui il manque des mots :) )

    J’ai réinstaller Novacom sans succés. D’ou vient le probleme ?

    Merci

    Roxarmy

    (27 août 2011 - 20:44)

    @Manu : Lorsque vous branchez votre appareil, vous ne touchez à rien, je veux dire que vous n’activez pas le “lecteur USB” ? Essayer un autre port USB afin que windows réinstalle les drivers

    Manu

    (27 août 2011 - 20:50)

    Non je n’active pas le lecteur USB, j’ai essayer sur les 3 ports USB c’est la même chose…

    Y’a une version mac du soft ?

    Roxarmy

    (27 août 2011 - 21:08)

    @Manu : essayer ce fichier http://dl.dropbox.com/u/2774158/WebOSQuickInstall-4.2.3.jar

    Normalement java est multiplateforme mais on ne sais jamais ;)

    Au pire voici un tuto pour l’installer via le SDK : http://www.webos-internals.org/wiki/Application:Preware#Installing_Preware_using_the_Official_HP.2FPalm_SDK (tuto en anglais)

    Manu

    (27 août 2011 - 21:11)

    Je viens d’essayer sur Mac, même chose, la tablette n’est pas détectée… on me demande à chaque fois de connecter un périphérique…

    Manu

    (27 août 2011 - 21:20)

    Merci beaucoup pour les liens, je tente via le SDK à mon retour du ciné, je vous tiendrai au courant.

    Jayzi

    (28 août 2011 - 01:46)

    @Manu

    Il faut que tu actives le Developer Mode en cliquant sur ” Non ” en haut à droite de l’écran pour le faire passer en ” Oui ”

    Rajoutez-le peut-être à votre tutoriel parce qu’on ne va pas être les seuls dans cette situation là :)

    Merci pour le tuto en tout cas!

    Manu

    (28 août 2011 - 13:40)

    @Jayzi

    J’avais bien activé le Developer Mode mais merci quand même.

    J’ai testé via le SDK avec le lien de Roxarmy et je ne comprends pas ce qu’il faut faire à l’étape 8. Je me retrouve avec Virtual Box et Palm Emulator ainsi que le fichier org.webosinternals.preware_1.7.0_arm.ipk et je capte pas ce que je dois faire…

    Asthaine

    (28 août 2011 - 15:24)

    J’ai bien suivi les recommandations pour installer le preware, mais moi de mon côté, lorsque je suis dans webosquickinstall, je tape “preware” dans le champ de recherche, puis sur “installer”.

    A ce moment là j’ai bien un popup qui apparaît avec le téléchargement, puis 2 secondes après j’ai un popup qui s’affiche avec le message :
    “ERREUR: Impossible de télécharger org.webosinternals.preware_1.7.3_arm.ipk”.

    Je clique sur “OK” (seul choix) et là je retourne au champ de recherche…

    J’ai bien activé le mode développeur, je n’ai pas mis le touchpad en “stockage de masse”…

    Avez vous un avis sur le problème ?

    Roxarmy

    (28 août 2011 - 15:55)

    @Asthaine : Essayez ceci :
    Arrêtez vous à l’étape où il faut cliquer sur le globe avec les deux flèches, càd une fois branché ne faites rien.
    Télécharger ça http://get.preware.org/org.webosinternals.preware.ipk et glissez-le au milieux de l’écran, puis cliquer sur Installer ;)

    Asthaine

    (28 août 2011 - 16:08)

    @Roxarmy :
    Merci beaucoup je vais essayer ça dans les minutes qui suivent et je vous tiens au courant.

    Manu

    (28 août 2011 - 18:04)

    Bon après une dizaines de nouveaux essais avec webos quick install, j’ai réussi.

    Merci pour vos conseils.

    Asthaine

    (28 août 2011 - 18:09)

    @Roxarmy :
    Niquel Roxarmy, ça fonctionne, le logiciel l’a pris et Preware est bien sur ma tablette.
    Je te remercie.

    A moins que j’ai mal lu, tu ne l’as pas précisé dans ton tutoriel, n’hésites pas à le faire.

    Merci encore et bon courage pour la suite !

    sindara

    (29 août 2011 - 05:44)

    je n’arrive pas à ouvrir WebOsQuickInstall sur le pc.
    merci de votre aide.

    Roxarmy

    (29 août 2011 - 10:12)

    @Sindara : il faut avoir java d’installer : http://www.java.com/fr/

    sindara

    (29 août 2011 - 10:39)

    Je suis vraiment trop bête, après avoir installer
    “java installer” , j’accède enfin à WebOsQuickInstall mais l’action de cliquer sur le “petit globe” ne fait rien du tout.Pas de téléchargement.
    mille excuses pour le dérangement.

    Roxarmy

    (29 août 2011 - 11:46)

    @sindara : Essayez ceci :
    Arrêtez vous à l’étape où il faut cliquer sur le globe avec les deux flèches, càd une fois branché ne faites rien.
    Télécharger ça http://get.preware.org/org.webosinternals.preware.ipk et glissez-le au milieux de l’écran, puis cliquer sur Installer

    sindara

    (30 août 2011 - 09:16)

    j’ai téléchargé preware.ipk, cliqué sur Installer.
    Rien n’y fait.
    merci pour tout.

    Roxarmy

    (30 août 2011 - 09:26)

    @sindara : vous l’avez glissez dans la fenêtre comme montré sur le tuto ?

    etienne

    (30 août 2011 - 19:26)

    Bonjour,

    Pour ma part, “WebOS Quick Install” reste figer après l’installation des drivers. L’appareil est branché, mais pas détecté.

    Je ne sais pas quoi faire. :(
    Merci.

    sindara

    (1 septembre 2011 - 09:49)

    Roxarmy

    (1 septembre 2011 - 19:20)

    @etienne : Essayer de désinstaller le driver et réinstaller, sinon essayer sur un autre ordi
    @Sindara : Faut pas perdre espoir ^^ Essayez sur un autre PC

    jonathan

    (4 septembre 2011 - 11:31)

    Merci pour ce tuto sympa et très utile, faut-il désactiver “dev mode” à la fin?

    Merci

    Roxarmy

    (4 septembre 2011 - 12:19)

    @jonathan : Non, il faut le garder. Et ne vous inquiétez pas, cela ne change rien au niveau de l’utilisation de la tablette et il n’y a aucun risque.

    Didier

    (4 septembre 2011 - 20:31)

    Bonjour,

    idem, je suis l’heureux nouveau propriétaire de l

    Didier

    (4 septembre 2011 - 20:34)

    et j’ai un ptit problème.
    J’arrive à lancer l’installation de pre

    mais elle ne se termine pas. Donc pas installé.

    Message : “Installation :org.webosinternals.preware_1.7.5_arm.ipk”

    Et ca tourne sans fin. j’en suis à 30 minutes. Donc, je coupe ce n’est pas normal.

    Comprend pas après plusieurs essai

    kain

    (7 septembre 2011 - 21:54)

    génial merci pour le tuto

    arnaud

    (14 septembre 2011 - 23:15)

    bonsoir Roxarmy
    Je suis dans le même cas que manu avec le même message d erreur.
    J ai vraiment tout essayé même sur un autre pc mais rien ni fait la tablette n est pas détecté par webosquickinstall.
    pouvez vous m aider svp.
    avec mes remerciements

    Roxarmy

    (15 septembre 2011 - 18:41)

    @arnaud : Essayez de mettre à jour java. Soyez certain que vous êtes en mode développeur, utiliser le câble d’origine et surtout que vous n’avez pas d’activer le mode stockage de masse (lorsque vous le branchez au pc, ne touchez pas à la touchpad).
    Et si au pire vous n’y arrivez toujours pas, voici un autre tuto pour installer preware d’une autre manière : http://www.webos-internals.org/wiki/Application:Preware#Installing_Preware_using_the_Official_HP.2FPalm_SDK

    jie

    (19 septembre 2011 - 16:48)

    j’ai le même soucis impossible de détecter la tablette sur 3 pc différent !!!! Quelqu’un a résolu le soucis ?,,

    dmarq

    (2 octobre 2011 - 17:17)

    Bonjour

    J’ai un problème avec l’installation de Preware sur mon Touchpad. J’ai réussi à installer Preware sur celui-ci mais lorsque je l’exécute, j’obtiens une erreur pendant le téléchargement des informations des flux (qui fonctionne correctement pendant plusieurs secondes avant de m’afficher une erreur). L’erreur que je reçois indique une ‘bad address pour ipkg.preware.org’

    merci à l’avance

    Puce

    (19 octobre 2011 - 22:24)

    Bonjour,
    Sera t-il possible d’installer preware sous la version WebOS 3.0.4? Sans devoir downgrader? :roll:
    Cordilament

    Roxarmy

    (20 octobre 2011 - 09:46)

    @Puce : Normalement oui, pour ma part j’ai fais la mise à jour 3.0.2 > 3.0.4 sans rien désinstaller. Une fois la mise à jour réalisé, Preware était toujours présent :)

    Stanowski

    (20 octobre 2011 - 12:25)

    Bonjour
    j’ai fait la mis à jour en 3.0.4. mon touchpad a buggé, etj’ai été obligé d’utiliser Webos Doctor pour un retour à la normal. Depuis j’ai réinstaller Preware et impossible de retrouver les patchs ou application que j’avais installé avant … Touchpalyer (qui marchait bien, introuvable) ainsi que tous les patchs pour améliorer le fonctionnement dy TP. Comment faire pour les retrouver ? J’aurai du désisntaller les patchs avant la mise à jour, mais comment fait on cela ?
    En vous remerciant
    Stan

    Marie

    (20 octobre 2011 - 13:12)

    Bonjour,

    J’ai un cas un peu différent… J’ai désinstallé les patchs du preware avant de faire la mise à jour 3.0.4. La mise à jour s’est bien déroulée, mais depuis je ne retrouve plus les patchs que j’ai désinstallé dans le preware… Donc impossible de les remettre Bizarre !

    Roxarmy

    (20 octobre 2011 - 13:56)

    @Stanowski & @Marie : Il faut laisser le temps aux développeurs de mettre à jour leurs patchs. Car pour le moment, la plupart des patchs ne fonctionnent plus sur la 3.0.4

    Stan

    (20 octobre 2011 - 18:18)

    Ok, merci pour ces infos Pour la prochaine mise à jour, nous attendrons que les patchs aient été mis à jour avant de faire l’upgrade. :oops:

    babe9216

    (30 octobre 2011 - 17:18)

    Bonjour, j’ai gagné une tablette TouchPad HP reçue avant hier et j’aimerais savoir comment faire la mise à jour 3.0.4 svp ? Merci d’avance.

    Besnard

    (19 décembre 2011 - 14:40)

    Bonjour,

    Je voudrais savoir si la garantie saute si l’ont installe le preware ?

    Y-a t-il des risques encourue par la tablette ?

    Cordialement

    mrblue

    (21 décembre 2011 - 18:36)

    Il faut vraiment que je me motive pour installer l’alpha d’android, tu aurais pas fait un petit tutô la dessus :D

    dif

    (24 décembre 2011 - 23:29)

    moi mon soucis c’est que sa prend énormément de temps je ne comprend pas :/

    girard

    (15 janvier 2012 - 21:00)

    trop biens merci

    M-com

    (4 octobre 2012 - 20:02)

    super tuto novacom ne voulai pas s instaler mais au final j avai oublier de valider le mode developer donc tout est bon merci !!!

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *